MyBB-Plugins Forums
Extended Buddy System 1.4 - Printable Version

+- MyBB-Plugins Forums (http://forums.mybb-plugins.com)
+-- Forum: Archived Forums (http://forums.mybb-plugins.com/Forum-Archived-Forums)
+--- Forum: MyBB 1.4.x (http://forums.mybb-plugins.com/Forum-MyBB-1-4-x)
+---- Forum: Paid Plugins (http://forums.mybb-plugins.com/Forum-Paid-Plugins)
+---- Thread: Extended Buddy System 1.4 (/Thread-Extended-Buddy-System-1-4)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23


RE: Extended Buddy System 1.3 - habs - 10-04-2009

@nyunyu
Go to ACP >> Templates & Styles >> Template >> Your Templates >> Post Bit Templates >> Postbit/Postbit_classic

Find this:
Code:
{$post['onlinestatus']}

Add this code after that:
PHP Code:
<a href="{$mybb->settings['bburl']}/member.php?action=profile&amp;buddies_action=sendrequest&amp;uid={$post['uid']}&amp;my_post_key={$mybb->post_code}"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/buddy.png" alt="Add As Buddy"></a

Use your own image..
This will appear beside your Username and Online Status Icons.

See attachment.


RE: Extended Buddy System 1.3 - nyunyu - 10-04-2009

I added theme to my forum and since I want all activated plugins to also installed on the new theme, I deactivate the plugin and reactivate it back. But upon reactivation, I got this:
Code:
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1050 - Table 'mybb_extended_buddy_requests' already exists
Query:
    CREATE TABLE `mybb_extended_buddy_requests` ( `rid` int(10) UNSIGNED NOT NULL auto_increment, `fromuid` bigint(30) UNSIGNED NOT NULL, `touid` bigint(30) UNSIGNED NOT NULL, `date` bigint(30) UNSIGNED NOT NULL default '0', PRIMARY KEY (`rid`) ) TYPE=MyISAM

please help.


RE: Extended Buddy System 1.3 - Diogo Parrinha - 10-04-2009

Re-download and re-upload all files and deactivate the plugin please.


RE: Extended Buddy System 1.3 - nyunyu - 10-04-2009

(10-04-2009, 07:28 PM)Pirata Nervo Wrote: Re-download and re-upload all files and deactivate the plugin please.

Why? The plugin is alread deactivated. The problem now is I can't reactivate it since it shows me that error.

Anyway, in case you still asked me to redownload and reupload, I have done so and still the same problem, I can't reactivate the plugin.

Thanks.


RE: Extended Buddy System 1.3 - Diogo Parrinha - 10-04-2009

delete that table from phpmyadmin.
And I told you to deactivate it in order to delete any existing tables


RE: Extended Buddy System 1.3 - spinning - 10-04-2009

I had the same problem a while ago. It seems that the deactivation not delete the table.
What I did is go to your database with for example phpmyadmin and delete that table.
Activate it again and it works.


RE: Extended Buddy System 1.3 - nyunyu - 10-04-2009

(10-04-2009, 08:28 PM)Pirata Nervo Wrote: delete that table from phpmyadmin.
And I told you to deactivate it in order to delete any existing tables

Ok, I will try to delete that table.
Yeah, I know deactivate a plugin supposedly will delete existing tables but this one in particular does not.


RE: Extended Buddy System 1.3 - Diogo Parrinha - 10-04-2009

Is it fixed?


RE: Extended Buddy System 1.3 - nyunyu - 10-04-2009

Works but:

- All profile views count was gone.
- Each time the plugin reactivate, it add another edit on profile. So, I have to manually edit the template to remove them.

So, basically this plugin should be improved so deactivation will remove template edit.


RE: Extended Buddy System 1.3 - Diogo Parrinha - 10-04-2009

The plugin works perfectly on my localhost, console world and test website