MyBB-Plugins Forums

Full Version: Bank System 2.2! A FIX for NewPoints 2.1!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ladies and Gentlemen,

This is likely the wrong place to make this post. But for some reason, I was unable to create a 'New Thread' within any other board, nor able to respond to the related threads in question. As such, this was my solution. To anyone in administration, feel free to do with this post as you will, perhaps to attach it to the Banking system thread itself.

Mihu's Bank System (2.2) is a comprehensive bank system. Nicely done. However, it cannot be installed into the newest version of Diogo Parrinha's Newpoints, that being NewPoints 2.1. Well, it cannot be installed without the tiniest of edits. But once that edit is done, you should have no problems. I know that the plugin is kept within the MyBB 1.6 Archived Plugins board, but there hasn't been any issues at all.

But first... Mihu's Bank? You can find it (>]HERE!]<)
It wouldn't do to have a topic about a fix without a link to the related thread. Big Grin


If you extract the bank system, you will need to find the NewPoints_bank.php file. That will be within the "Upload\inc\plugins\newpoints" folder. It is this file you need to edit so NewPoints will recognize it as a valid and compatible system.

Opening the file with Notepad, you will go down to the 47th line. The line to edit is highlighted thus...


function newpoints_bank_info()

{
return array(
"name" => "Bank System",
"description" => "Integrates a bank system with NewPoints.",
"website" => "http://www.mihaisurdeanu.ro",
"author" => "Surdeanu Mihai",
"authorsite" => "http://www.mihaisurdeanu.ro",
"version" => "2.2",
"guid" => "",
"compatibility" => "1*"
);
}


Yes, dear readers. The culprit is merely the line that says what version of NewPoints that this plugin is compatible. Just change the '1' into a '2' as you can shown below...

function newpoints_bank_info()
{
return array(
"name" => "Bank System",
"description" => "Integrates a bank system with NewPoints.",
"website" => "http://www.mihaisurdeanu.ro",
"author" => "Surdeanu Mihai",
"authorsite" => "http://www.mihaisurdeanu.ro",
"version" => "2.2",
"guid" => "",
"compatibility" => "2*"
);
}


And that's all you need to do! If you're installing it straight away, just rebundle it with the fix. If you already installed it, just upload the altered/fixed newpoints_bank.php into place. Or whatever. It was merely this line that flagged the system as being incompatible with the latest version of NewPoints.

For the record, I have not had a single problem with the banking system since this installation.
Thanks for sharing.
i love you so much mate Smile
I have decided to sticky this topic as it's a great tool to help people use the Bank system on myBB!