MyBB-Plugins Forums

Full Version: [Release] Shop 1.7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I get the same problem as mmadhank.

(while adding/editing item)
PHP Code:
Warning [2Illegal string offset 'class' Line664 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    664    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2006    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line666 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    666    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2006    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line664 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    664    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2008    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line666 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    666    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2008    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line664 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    664    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2009    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line666 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    666    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2009    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line664 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    664    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2010    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks
Warning 
[2Illegal string offset 'class' Line666 Fileadmin/inc/class_form.php PHP 5.4.12 (Linux)
File    Line    Function
/
admin/inc/class_form.php    666    errorHandler->error
/inc/plugins/newpoints/newpoints_shop.php    2010    DefaultForm->generate_yes_no_radio
/inc/class_plugins.php    101    newpoints_shop_admin
/inc/plugins/newpoints/core/hooks.php    49    pluginSystem->run_hooks
/inc/class_plugins.php    101    newpoints_admin_load_hook
/admin/index.php    521    pluginSystem->run_hooks 

After googling the warning code it seems that it's because of running PHP 5.4
Quote:As of PHP 5.4 string offsets have to either be integers or integer-like strings, otherwise a warning will be thrown. Previously an offset like "foo" was silently cast to 0.
http://php.net/manual/en/language.types.string.php

It's a problem in myBB really but still i can't add items to the shop. I'm going to move back to PHP 5.3 to see if it's gonna help.


EDIT: Well i was to lazy to reinstall php so i upgraded mybb to 1.6.10 dev files. No more error but my new items don't show in the shop
Thanks, I'll release a new version as soon as I fix it.
Oh well... Now I should take my HDD out and throw it to lava. Forgot to set visibility to groups for categories... Anyway i think that admins should see all items by default.
I'm confused. So there is no bug?
I've downloaded and installed "Newpoints 1.9.7" and "Shop 1.7" Buy in ACP->Newpoints->Plugins I can't activate shop 1.7 because it says it's not compatible with MyBB NEWPOINTS_VERSION.

what's wrong?
Thank you Big Grin
Are you sure you downloaded 1.7?
Hello, I do not want to keep on my external link to pictures of the products after she sold the picture does not look how we can make it
I'm get same problem, that shop 1.7 "this plugin is incompatible with mybb 1.9.7"
(04-08-2013, 03:40 AM)casusnet Wrote: [ -> ]Hello, I do not want to keep on my external link to pictures of the products after she sold the picture does not look how we can make it

What?

(04-08-2013, 10:49 PM)onfbooz Wrote: [ -> ]I'm get same problem, that shop 1.7 "this plugin is incompatible with mybb 1.9.7"

Please read the readme file properly, it seems you're putting the files in the wrong directory.
Just installed but I got this bug on the add category in admin panel.

[2] Illegal string offset 'class' - Line: 666 - File: admin/inc/class_form.php PHP 5.4.6-1ubuntu1.2 (Linux)

Warning [2] Illegal string offset 'class' - Line: 664 - File: admin/inc/class_form.php PHP 5.4.6-1ubuntu1.2 (Linux)