MyBB-Plugins Forums

Full Version: [Release] Shop 1.7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I already explained the problem, but okay, I've gone and done that. Now I hope you believe me.

[Image: shopbug.png]
is it possible to send message to both admin and the one who bought an item then when admin received it says "xxx has bought an item"? thanks
(01-27-2011, 09:41 AM)Mantis Wrote: [ -> ]I already explained the problem, but okay, I've gone and done that. Now I hope you believe me.

[Image: shopbug.png]

Image is down? Please upload it to a post here.


(01-27-2011, 12:24 PM)jcardy Wrote: [ -> ]is it possible to send message to both admin and the one who bought an item then when admin received it says "xxx has bought an item"? thanks

No it isn't possible to do that.
Here.
(01-28-2011, 04:15 AM)Pirata Nervo Wrote: [ -> ]
(01-27-2011, 12:24 PM)jcardy Wrote: [ -> ]is it possible to send message to both admin and the one who bought an item then when admin received it says "xxx has bought an item"? thanks

No it isn't possible to do that.

i've already solve the problem. it send both to admin and the one who bought the item, and when admin received, it says {username} has bought an item - {itemname}.

thanks.

i add this one in shop language php

Code:
$l['newpoints_shop_bought_item_pm_subject_admin'] = '{1} have bought an item - {2}';

and this one new points shop php.
Code:
newpoints_send_pm(array('subject' => $lang->sprintf($lang->newpoints_shop_bought_item_pm_subject, htmlspecialchars_uni($mybb->user['username']), htmlspecialchars_uni($item['name'])), 'message' => $item['pm'], 'touid' => 2, 'receivepms' => 2), -1);
@jcardy, yes that works fine but it's not "good" for other websites where the main admin may not be the user ID 2 but that works for you and that's all that matters Smile


(01-28-2011, 07:42 AM)Mantis Wrote: [ -> ]Here.

I'm currently pulling my hairs off my head since I just can't understand how the hell you're getting Mantis as the first word. I just tested it on my localhost and it worked very well, I sent an item from Pirata Nervo to test and here's a quote from the PM received by test:
' Wrote:Pirata Nervo has sent you the item Test.
(Item name is "Test")

And the code is correct as well. What are your steps so I can try to reproduce it again?
Go to Newpoints Shop. Buy an item. Send the item to a recipient. Then on the recipient's account (assuming you used a test account), check private messages. You would see what I see. I don't know why it happens either. Could it be because I'm using an old version of the shop plugin due to having MyBB 1.4x?
(01-29-2011, 06:03 AM)Mantis Wrote: [ -> ]Go to Newpoints Shop. Buy an item. Send the item to a recipient. Then on the recipient's account (assuming you used a test account), check private messages. You would see what I see. I don't know why it happens either. Could it be because I'm using an old version of the shop plugin due to having MyBB 1.4x?

What version do you have? That's most likely the reason...you could have told me that before. v1.1 and v1.2 have that problem but it was definitely fixed in 1.3
(01-29-2011, 05:48 AM)Pirata Nervo Wrote: [ -> ]@jcardy, yes that works fine but it's not "good" for other websites where the main admin may not be the user ID 2 but that works for you and that's all that matters Smile

yup, actually the main admin is 1, i set it to 2 because the main admin were always busy and could not always login in the forum. anyway thanks. this solved my problem Smile
So 1.3 is the last version supported by MyBB 1.4?