Hello There, Guest! › Register

MySubscriptions 2.2 released.
Looking for a custom plugin for your site? Ask here for a quote.

Login Box Not Functioning (Jquery involved)
#1

Alright, so I have a forum: http://forum.novalisgaming.net/index.php

I've swapped over from SMF 2.0 to MyBB, and I recently bought a theme and series of plugins.

The biggest issue I cannot understand, is why my login button does not work... If you click it, it is supposed to make a Jquery popup where you login from.

I'm not sure what's wrong, but below is the code involved for login and register functions.. Please tell me if you spot the issue.

PHP Code:
<!-- begin sidepanel 1 -->

            <
div class="sidepanel1">
             <
div class="tpanel" style="padding: 10px 6px;">
Welcome Guest!            
            </
div>

            <
div class="tpanel2" >
             
             
             <
div class="userstats2"> <br />&nbsp;
               <
class='inline' href="#login_box" style="margin-right: 10px;" id="login">Please sign in</a> or 
               <
a href="{$mybb->settings['bburl']}/member.php?action=register" style="margin-left: 10px;"  id="login">Create an account</a><br /><br />
 
             </
div>

         </
div>

     </
div>

     <!-- 
end sidepanel 1 -->
















        <
div style='display:none;'>
            <
div id='login_box' style='padding:0px; background:#181818; text-align: left;'>
                <
div class="thead" style="border-radius: 0px; padding: 10px 0 10px 0;margin-top:-2px;">
                    <
span class="largetext">&nbsp;Login to {$mybb->settings['homename']}</span>
                </
div>
                                            
                <
div style="padding: 10px;">
                    <
span style="font-size: 15px;">Please enter your username and password to log in.</span>
                    <
form class="form" action="member.php" method="post">
                            <
input name="action" value="do_login" type="hidden"/>
                            <
input name="url" value="{$mybb->settings['bburl']}type="hidden"/>
                            <
input name="quick_login" value="1" type="hidden"/>
                        <
div class="login_row">
                            <
input name="quick_username" id="quick_login_username" value="Username" class="login_input" onfocus="if(this.value == 'Username') { this.value=''; }" onblur="if(this.value == '') { this.value='Username'; }" type="text" size="35"/>
                        </
div>
                                                    
                        <
div class="login_row">
                            <
input name="quick_password" id="quick_login_password" value="Password" class="login_input" onfocus="if(this.value == 'Password') { this.value=''; }" onblur="if(this.value == '') { this.value='Password'; }" type="password" size="35"/>
                            <
class="forgot" href="{$mybb->settings['bburl']}/member.php?action=lostpw">Forgot my password</a>
                        </
div>
                                                    
                        <
div class="login_row">
                            <
input name="quick_remember" id="quick_login_remember" value="yes" class="checkbox" type="checkbox"/>
                            <
label>Keep me signed in</label>
                        </
div>

                        <
div class="login_row">
                            <
input name="submit" value="Login" class="button" type="submit" title="Login"/>
                            <
input value="do_login" name="action" type="hidden"/>
                            <
input value="" name="url" type="hidden"/>
                        </
div>
                    </
form>
                </
div>
            </
div>
        </
div
[Image: AnaNVS---.png]
Reply
#2

Hi,

I will only be home on the 11th, I can only speak then.
To download our paid plugins and receive support you must be a paid subscriber. Click here for more information.
Reply
#3

Alright, thank you.
[Image: AnaNVS---.png]
Reply
#4

Sorry! On my phone only
To download our paid plugins and receive support you must be a paid subscriber. Click here for more information.
Reply
#5

Are you using Cloudflare? This seems to cause the problem.

Please try to disable Rocket Loader. Maybe this will fix your problem. Give it a try and report back please.
Regards from Germany
Kenny
[Image: mybbservice_signatur.png]
Reply
#6

(08-09-2014, 07:09 AM)Kenny Wrote: Are you using Cloudflare? This seems to cause the problem.

Please try to disable Rocket Loader. Maybe this will fix your problem. Give it a try and report back please.

I was not using Cloudflare when this problem occured... It just never worked out of the box for some unknown reason.

However, I do -now- use CloudFlare.
[Image: AnaNVS---.png]
Reply
#7

Well I've read your post carefully now on my laptop finally and all I can say is that it may depend on a lot of things and you should contact the author of your theme for support.
To download our paid plugins and receive support you must be a paid subscriber. Click here for more information.
Reply




Users browsing this thread: 1 Guest(s)