Hello There, Guest! › Register

MySubscriptions 2.2 released.
Looking for a custom plugin for your site? Ask here for a quote.

Community Threads For MyPlaza Turbo?
#1

Hi,
I don't see a "New threads" button in the MyPlaza Turbo section, obviously you are no longer supporting or wanting endless questions.
Can people still post somewhere with "Community Threads" to help each other?

For example:
Updating any items gives this error in the admin section (php5.3+)
Quote:Warning [2] substr() expects parameter 2 to be long, string given - Line: 1187 - File: inc/myplaza/inventory_admin_plugin.php PHP 5.3.1 (Linux)

How to fix (suppress) the php5.3 bug in MyPlaza Turbo Inventory Items Admin:

Step 1)
./inc/myplaza/inventory_admin_plugin.php
line 1187 find
PHP Code:
    if(($item['includefile'] == 'inventory' && ($item['idname'] == 'inventory_item') || ($mybb->settings['mycompany_bridge_inventory'] == MY_YES && substr('/mycompany_item_/'$item['idname'])))) 
replace with
PHP Code:
    if(($item['includefile'] == 'inventory' && ($item['idname'] == 'inventory_item') || ($mybb->settings['mycompany_bridge_inventory'] == MY_YES && @substr('/mycompany_item_/'$item['idname'])))) 

Step 2)
There are two more lines just below where you can add @ before 'substr'
FYI: This suppresses the errors, if I find out a better way to fix, then I will update.

#
Can we still get a tiny little sub-forum for MyPlaza Turbo? Smile
Thanks
My new signature has not been created, yet. Angel
Reply
#2

No, the MyPlaza Turbo forum is closed because I do not want to give support for it.
Simple as that Smile
To download our paid plugins and receive support you must be a paid subscriber. Click here for more information.
Reply




Users browsing this thread: 1 Guest(s)